How can I install the flinc app on my iPhone or iPad?

You will find our iOS app in the iTunes Appstore: Install iOS app

System requirements:
iOS 7 or later

Have more questions? Submit a request

Comments

Powered by Zendesk